View unanswered posts | View active topics It is currently Tue Sep 30, 2014 3:57 pm



Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
 Problems installing OpenRPG on OS X 10.6 
Author Message

Joined: Thu Dec 10, 2009 6:37 am
Posts: 335
Post Re: Problems installing OpenRPG on OS X 10.6
I don't know how to set an environment variale in Mac OS but judging by what they are saying one way to do it is to edit this file they mention called .bash_profile.

"That variable was being set in my .bash_profile"

or Google it:

http://www.google.com/search?q=how+do+I+set+user+environment+variables+in+mac+os%3F&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a


Tue Aug 03, 2010 11:46 pm
Profile

Joined: Sun Aug 01, 2010 3:40 am
Posts: 8
Post Re: Problems installing OpenRPG on OS X 10.6
davidbyron wrote:
I don't know how to set an environment variale in Mac OS but judging by what they are saying one way to do it is to edit this file they mention called .bash_profile.

"That variable was being set in my .bash_profile"

or Google it:

http://www.google.com/search?q=how+do+I+set+user+environment+variables+in+mac+os%3F&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Yeah, none of that is helpful because I don't understand what they're talking about. I'm just going to copy what "man python" has to say about changing to 32-bit mode:

Quote:
64-BIT SUPPORT
Versions 2.6 and 3.0 support 64-bit execution (which is on by default).
Version 2.5 only supports 32-bit execution.

Like the version of Python, the python command can select between 32 and
64-bit execution (when both are available). Use:

% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes

to make 32-bit execution the user default (using
`/Library/Preferences/com.apple.versioner.python' will set the system-
wide default). The environment variable VERSIONER_PYTHON_PREFER_32_BIT
can also be used (has precedence over the preference file):

% export VERSIONER_PYTHON_PREFER_32_BIT=yes # Bourne-like shells
or
% setenv VERSIONER_PYTHON_PREFER_32_BIT yes # C-like shells

Again, the preference setting and environmental variable applies to both
python and pythonw.



I have tried entering all three of those commands and have gotten the following every time:

Quote:
>>> % defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
File "<stdin>", line 1
% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
^
SyntaxError: invalid syntax


I get the same error no matter what command I use. Like I said, I don't have a head for all of this programming stuff. If someone can figure out what I'm supposed to type I'll do it, but I honestly have no idea what I'm doing.


Wed Aug 04, 2010 12:38 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
It would help if you told us what command you are running.

I do apologize for the lack of Mac support. Python helps Traipse achieve platform universality, however there are few Mac users. I am surprised Paul has not chimed in with some advice.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Wed Aug 04, 2010 1:14 am
Profile YIM WWW

Joined: Sun Aug 01, 2010 3:40 am
Posts: 8
Post Re: Problems installing OpenRPG on OS X 10.6
prof.ebral wrote:
It would help if you told us what command you are running.

I do apologize for the lack of Mac support. Python helps Traipse achieve platform universality, however there are few Mac users. I am surprised Paul has not chimed in with some advice.

The command I've been using is "% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes" just like "man python" said.


Wed Aug 04, 2010 1:51 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
ultramatt17 wrote:
The command I've been using is "% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes" just like "man python" said.


I think you are doing it wrong is all. Try defaults write com.apple.versioner.python Prefer-32-Bit 1

If that doesn't work you can add VERSIONER_PYTHON_PREFER_32_BIT=yes .profile

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Wed Aug 04, 2010 2:08 am
Profile YIM WWW

Joined: Thu Dec 10, 2009 4:16 pm
Posts: 89
Post Re: Problems installing OpenRPG on OS X 10.6
I haven't said anything because I haven't been sure about what to do.

I've never run across this problem before so I'm learning at the same rate you are but believe me you can get it running.

I do know this, leave the % off of the command line.

That only denotes the beginning of the command line.

I think some systems use it but mac does not.


Wed Aug 04, 2010 4:58 am
Profile

Joined: Sun Aug 01, 2010 3:40 am
Posts: 8
Post Re: Problems installing OpenRPG on OS X 10.6
Paul wrote:
I haven't said anything because I haven't been sure about what to do.

I've never run across this problem before so I'm learning at the same rate you are but believe me you can get it running.

I do know this, leave the % off of the command line.

That only denotes the beginning of the command line.

I think some systems use it but mac does not.

I...I think I've got it! Now I have the OpenRPG Udater window open, and it's updating. The program itself should launch after the update, correct? If not, I'll post again, but until then thanks Paul, prof.ebral and davidbyron. Sorry if I came off a bit short, but all of this stuff can be pretty daunting for someone who has never done it before.

EDIT: It's up and running. Thanks again for all the help, guys!


Wed Aug 04, 2010 5:17 am
Profile

Joined: Thu Dec 10, 2009 4:16 pm
Posts: 89
Post Re: Problems installing OpenRPG on OS X 10.6
Thank you.

You did all the hard work figuring out what need to be done we just nudged you along the way.

The end result is we all learned something new and you've helped anyone in the future who may also have this problem.

So you just made your first contribution to the OpenRPG system. :D

Game on and enjoy.


Wed Aug 04, 2010 2:46 pm
Profile

Joined: Thu Dec 10, 2009 6:37 am
Posts: 335
Post Re: Problems installing OpenRPG on OS X 10.6
We could do with a MAC-only issues thread stickied.


Tue Aug 10, 2010 8:04 pm
Profile

Joined: Fri Jun 25, 2010 12:54 am
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
You said "latest" Version of Python and "man Python" clearly notes Version 3.0.

Both forks do not work with the most recent Versions, especially not with 3.0 or higher. Recomended Versions are listed here

Please run "system_check.py", locate the "openrpg_sysinfo.txt" it creates and post it's contents here.


Mon Sep 06, 2010 4:19 pm
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.