View unanswered posts | View active topics It is currently Sat Sep 20, 2014 8:00 am



Post new topic Reply to topic  [ 4 posts ] 
 Trouble Launching: Image file is not type 13 
Author Message

Joined: Thu Apr 21, 2011 5:57 am
Posts: 2
Post Trouble Launching: Image file is not type 13
Hi All :)

Im very new to the OpenRPG world, so please be kind, I have a Macbook and have been trying for a few days to get openRPG running with no luck, So I thought maybe I'd post my issue and some kind person could perhaps help me?

I followed the notes in this link to ensure i have the latest version:

viewtopic.php?f=4&t=496

When I run start_client.py from my applications folder, and run the Python module I see the OpenRPG Splash screen, it then flicks away and the following error is shown:

ERROR:

Image file is not of type 13.

The shell log shows this:

Rooting OpenRPG at: /Applications/OpenRPG1
Traceback (most recent call last):
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/main.py", line 1315, in AfterSplash
self.frame = orpgFrame(None, wx.ID_ANY, CLIENT_STRING)
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/main.py", line 121, in __init__
self.build_gui()
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/main.py", line 731, in build_gui
self.build_window(c, self)
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/main.py", line 867, in build_window
wx.DefaultSize)
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/chat/chatwnd.py", line 345, in __init__
self.MainChatPanel = chat_panel(self, -1, MAIN_TAB, 'all')
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/chat/chatwnd.py", line 577, in __init__
self.build_ctrls()
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/chat/chatwnd.py", line 984, in build_ctrls
self.build_bar()
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/chat/chatwnd.py", line 1044, in build_bar
self.build_formating()
File "/Applications/OpenRPG1/orpg/tools/decorators.py", line 106, in new_func
return func(*args, **kwargs)
File "/Applications/OpenRPG1/orpg/chat/chatwnd.py", line 1181, in build_formating
wx.ID_ANY, '#bdbdbd')
File "/Applications/OpenRPG1/orpg/orpg_windows.py", line 657, in createMaskedButton
gif = wx.Image( image, image_type, ).ConvertToBitmap()
File "/usr/local/lib/wxPython-unicode-2.8.10.1/lib/python2.6/site-packages/wx-2.8-mac-unicode/wx/_core.py", line 3369, in ConvertToBitmap
return _core_.Image_ConvertToBitmap(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "image.Ok()" failed at /BUILD/wxPython-src-2.8.10.1/src/mac/carbon/bitmap.cpp(1286) in wxBitmap(): invalid image


I wonder if someone else has had this problem and if they have, maybe they could help a newbie to start playing :-)

Thanks

Healaxe


Thu Apr 21, 2011 6:04 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Trouble Launching: Image file is not type 13
Download and use my Traipse fork of OpenRPG: http://traipse.assembla.com/spaces/traipse

I have not seen the current developers of 'standard' doing anything for several months.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Thu Apr 21, 2011 2:22 pm
Profile YIM WWW

Joined: Thu Apr 21, 2011 5:57 am
Posts: 2
Post Re: Trouble Launching: Image file is not type 13
Thanks ! :-)

All works now after using your App!

Thanks!

Healaxe


Sun Apr 24, 2011 1:48 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Trouble Launching: Image file is not type 13
You are welcome!

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sun Apr 24, 2011 3:08 am
Profile YIM WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.