View unanswered posts | View active topics It is currently Fri Oct 31, 2014 2:20 pm



Post new topic Reply to topic  [ 3 posts ] 
 Traipse and Python 2.7 on a 1.8.0 Server 
Author Message
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Traipse and Python 2.7 on a 1.8.0 Server
Today I was informed of an error that occurs when the above combination has mixed. The user was using Traipse Beta 100811-02, the server is an unknown build of 1.8.0 (they could keep better track).

The user was sending data to everyone in the server, however when data was sent to the user it would not pre-translate correctly, causing the user to not see anything. I brought the user to the Living Knowledge Arcana server running Traipse 100919-00 and the issue was not experienced.

Are other users who have installed Python 2.7 having similar network issues?

FYI: Python 2.7 has not been tested with Traipse, and it apparently creates issues. I do not know if Python 2.7 has been tested with 1.8.0 but I have noticed a recent string of users having problems with OpenRPG after having installed Python 2.7

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Thu Aug 12, 2010 4:52 am
Profile YIM WWW

Joined: Thu Dec 10, 2009 6:37 am
Posts: 335
Post Re: Traipse and Python 2.7 on a 1.8.0 Server
It hasn't been tested with 1.8.0 ... or any version of OpenRPG of either fork.

I recommend Python 2.6 and wxPython 2.8.10.1 (as provided by the most recent windows installer). I assume the same goes for Traipse? Although maybe you have that known bug for wxPython 2.8.11.0 fixed with Traispe... but still there may be others.

Not to say there's bound to be errors with different Python versions..... in fact it seems to me that the wxPython versions are more likely to cause problems than Python.

It's possible this issue is related to the "new" messaging system,

http://www.assembla.com/wiki/show/openrpg/Old_vs_New_Messaging_System


Thu Aug 12, 2010 5:30 pm
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Traipse and Python 2.7 on a 1.8.0 Server
davidbyron wrote:
It hasn't been tested with 1.8.0 ... or any version of OpenRPG of either fork.
In that case we need to get the word out that Python 2.7 and wx.Python 2.8.11 are causing problems.
Quote:
I recommend Python 2.6 and wxPython 2.8.10.1 (as provided by the most recent windows installer). I assume the same goes for Traipse?
Traipse can live well under those versions.I don't think that is the problem. I am more inclined to believe it is related to the changes made to ElementTree.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Thu Aug 12, 2010 5:42 pm
Profile YIM WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.