View unanswered posts | View active topics It is currently Thu Oct 02, 2014 10:27 am



Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
 Problems installing OpenRPG on OS X 10.6 
Author Message

Joined: Thu Jul 07, 2011 11:14 pm
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
Yeah, none of that is helpful because I don't understand what they're talking about. I'm just going to copy what "man python" has to say about changing to 32-bit mode:

Quote:
64-BIT SUPPORT
Versions 2.6 and 3.0 support 64-bit execution (which is on by default).
Version 2.5 only supports 32-bit execution.

Like the version of Python, the python command can select between 32 and
64-bit execution (when both are available). Use:

% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes

to make 32-bit execution the user default (using
`/Library/Preferences/com.apple.versioner.python' will set the system-
wide default). The environment variable VERSIONER_PYTHON_PREFER_32_BIT
can also be used (has precedence over the preference file):

% export VERSIONER_PYTHON_PREFER_32_BIT=yes # Bourne-like shells
or
% setenv VERSIONER_PYTHON_PREFER_32_BIT yes # C-like shells

Again, the preference setting and environmental variable applies to both
python and pythonw.



I have tried entering all three of those commands and have gotten the following every time:

Quote:
>>> % defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
File "<stdin>", line 1
% defaults write com.apple.versioner.python Prefer-32-Bit -bool yes
^
SyntaxError: invalid syntax


I get the same error no matter what command I use. Like I said, I don't have a head for all of this programming stuff. If someone can figure out what I'm supposed to type I'll do it, but I honestly have no idea what I'm doing.[/quote]

Okay, I was able to follow everything up to about here.

Here is my main issue, I can't find com.apple.versioner.python command in my library/preferences.
I can see tons of other com.apple.(Yadda, Yadda)'s but I can't see the versioner, anyone know why?


Sat Jul 09, 2011 4:47 pm
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
can you type:

python --version

in your terminal and post the output here?

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sat Jul 09, 2011 5:04 pm
Profile YIM WWW

Joined: Thu Jul 07, 2011 11:14 pm
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
XXX-imac:~ XXX$ python --version
Python 2.7.2

(The XXX's are to censor out my name.)

BBut yeah thats what I got.


Sat Jul 09, 2011 9:45 pm
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
That's the problem. Python 2.5 is the only version that supports 32bit.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sun Jul 10, 2011 12:39 am
Profile YIM WWW

Joined: Thu Jul 07, 2011 11:14 pm
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
So will I have to install the Python 2.5 to get it to work?


Sun Jul 10, 2011 1:09 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
I think so.

You could try this option: http://stackoverflow.com/questions/2565 ... ow-leopard

It's a simple attempt that should be an easy try, at the very least. The real problem is wxPython, not Python.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sun Jul 10, 2011 2:03 am
Profile YIM WWW

Joined: Thu Jul 07, 2011 11:14 pm
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
I tried installing Python 2.5.4 that didn't work and before that I tried what it said in that link, to simular results.

Am I an idiot or is there something fundamental I'm screwing up here?


Sun Jul 10, 2011 2:49 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
No. Probably.
I don't have a Mac OS X system to test on, so I am really not much help here.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sun Jul 10, 2011 3:06 am
Profile YIM WWW

Joined: Thu Jul 07, 2011 11:14 pm
Posts: 18
Post Re: Problems installing OpenRPG on OS X 10.6
Okay, I took a moment to delete and reinstall everything by the book when I launch my Start client I get the following message on my terminal(XXX will replace my name)

cd '/Users/XXX/Downloads/OpenRPG1.8.0 (1)/' && '/usr/local/bin/pythonw'
'/Users/XXX/Downloads/OpenRPG1.8.0 (1)/start_client.py' && echo Exit status: $? && exit 1
XXX-imac:~ aborneo$ cd '/Users/XXX/Downloads/OpenRPG1.8.0 (1)/' && '/usr/local/bin/pythonw' '/Users/XXX/Downloads/OpenRPG1.8.0 (1)/start_client.py' && echo Exit status: $? && exit 1
Traceback (most recent call last):
File "/Users/XXX/Downloads/OpenRPG1.8.0 (1)/start_client.py", line 7, in <module>
runpy.run_module('updater.gui', run_name='__main__', alter_sys=True)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 176, in run_module
fname, loader, pkg_name)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 82, in _run_module_code
mod_name, mod_fname, mod_loader, pkg_name)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 72, in _run_code
exec code in run_globals
File "/Users/XXX/Downloads/OpenRPG1.8.0 (1)/updater/gui.py", line 8, in <module>
import wx
File "/usr/local/lib/wxPython-ansi-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-ansi/wx/__init__.py", line 45, in <module>
from wx._core import *
File "/usr/local/lib/wxPython-ansi-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-ansi/wx/_core.py", line 4, in <module>
import _core_
ImportError: dlopen(/usr/local/lib/wxPython-ansi-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-ansi/wx/_core_.so, 2): no suitable image found. Did find:
/usr/local/lib/wxPython-ansi-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-ansi/wx/_core_.so: no matching architecture in universal wrapper
XXX-imac:OpenRPG1.8.0 (1) XXX$

So can anyone work their computer/voodoo magic?


Sun Jul 10, 2011 3:11 am
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Problems installing OpenRPG on OS X 10.6
/usr/local/lib/wxPython-ansi-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-ansi/wx/_core_.so: no matching architecture in universal wrapper

See that? This 'no matching architecture in universal wrapper' is referring to 32bit / 64bit. Python in Mac OSX defaults to 64bit and wxPython does not have a 64bit implementation.

I also noticed you are using wxPython 1.8.12. As far as I remember, Python 2.7+ and wx.Python 1.8.11+ do not work with OpenRPG. Sorry about that. The developers for 'standard' have stopped developing and I am replacing wxPython with PyQt in Traipse.

viewtopic.php?f=4&t=496

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Sun Jul 10, 2011 3:32 am
Profile YIM WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next


Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.