View unanswered posts | View active topics It is currently Fri Nov 21, 2014 2:28 am



Post new topic Reply to topic  [ 2 posts ] 
 OpenRPG on Mac OSX Lion 
Author Message

Joined: Fri Jan 08, 2010 4:06 am
Posts: 4
Post OpenRPG on Mac OSX Lion
Anyone get this to work on OSX Lion? I had ORPG working under Snow Leopard, but recently upgraded. Everything I've read indicated that wxPython 2.8 doesn't work under Lion, because it's 64bit, and the recommendation was to get wx 2.9 (which doesn't seem to work with ORPG)...

I modified a file so it looks and recognizes wx 2.9, I can get the updater (which I skip for now) and then it crashes (I don't get the splash screen or anything).

System_Info:
OpenRPG System Info 11-04-11
OpenRPG Version: 1.8.0
OpenRPG Build: 090712-00
Python: 2.7.2 (v2.7.2:8527427914a2, Jun 11 2011, 15:22:34)
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]
wxPython Version: 2.9.2.4
Platform: Darwin-11.2.0-x86_64-i386-64bit

Here's the error message I get after the updater closes:
Code:
Rooting OpenRPG at: /Users/<userdir>/openrpg

You do not have the correct version of wxPython installed, please
Download the correct version
Traceback (most recent call last):
  File "/Users/<userdir>/openrpg/start_developer.py", line 4, in <module>
    runpy.run_module('start_client', run_name='__main__', alter_sys=True)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 176, in run_module
    fname, loader, pkg_name)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 82, in _run_module_code
    mod_name, mod_fname, mod_loader, pkg_name)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/Users/<userdir>/openrpg/start_client.py", line 13, in <module>
    import orpg.main
  File "/Users/<userdir>/openrpg/orpg/main.py", line 34, in <module>
    from orpg.orpg_windows import *
  File "/Users/<userdir>/openrpg/orpg/orpg_windows.py", line 75, in <module>
    class orpgTabberWnd(FNB.FlatNotebook):
NameError: name 'FNB' is not defined


Can anyone help me out?

Thanks,


Fri Nov 04, 2011 4:31 pm
Profile
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: OpenRPG on Mac OSX Lion
I don't have the information in front of my because with Pious Paladin we've moved on to a more stable UI library, but I do remember this part. You need to look at the wxPython documentation. Names have been changed from 2.8 to 2.8.11 that made it not worth the effort to switch.

I can't help you with this, I just know where you need to look.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Fri Nov 04, 2011 6:12 pm
Profile YIM WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.