View unanswered posts | View active topics It is currently Wed May 27, 2020 8:26 am



Post new topic Reply to topic  [ 7 posts ] 
 Failed to connect to server... 
Author Message
User avatar

Joined: Wed Jun 09, 2010 1:24 am
Posts: 23
Post Failed to connect to server...
I am new to openrpg but not entirely new. I was successful in connecting to servers in the past, infact just 4 days ago. I used standard 1.8.0.5 and had no problems. My problems started when I tried to switch over to Traipse (the latest one, something orc). Well after I stumbled around on how to install that, I finally got that to go to the update manager. I managed to get the main screen up but nothing would populate in the server gui list. So I tried to run openrpg (standard) and a gui list populated but every bold black server (not hidden) would just "failed to connect to server..." I made sure both programs had access through my firewall (i am running windows 7, no router) on the port people specified (6774 or something like that) as well as making sure the server list was up to date (forget the link but it was in another post by the traispe developer I think "I ate your death knell" was in his signature). So I uninstalled both applications and all the python files and reinstalled openrpg standard after rebooting only to run into the "failed to connect to server..." problem again.

What happened?

How can I fix it?

How can I get both openrpg and Traipse to work?

Thank you.

_________________
My Gaming Group's Home Page For All Our Games

My Pathfinder [3.7] Home Brewed Campaign Forum

My Pathfinder [3.7] Home Brewed Campaign Mayhem Gaming Forum


Wed Jun 09, 2010 1:33 am
Profile WWW
User avatar

Joined: Wed Dec 09, 2009 9:39 pm
Posts: 712
Post Re: Failed to connect to server...
The server GUI list problem is my fault. i am actively working on Patch-3, the final Ornery Orc patch.

There is a file in your templates folder called default_metaservers.xml. Just copy that to your myfiles directory and rename it to metaservers.xml

That will fix the server list in Traipse. Sorry about the issue, I am working on support for multiple metas and I have to juggle some recovered meta server code as well as trying to add the feature without breaking the software. And as you can see, I failed.

_________________
I ate your Death Knell.
The Traipse Movement
Please show your support for Traipse OpenRPG http://www.facebook.com/MadMathLabs
Send me Traipse OpenRPG Ideas, Bugs, Complaints, Praises here: https://getsatisfaction.com/mml


Wed Jun 09, 2010 3:01 am
Profile YIM WWW
User avatar

Joined: Wed Jun 09, 2010 1:24 am
Posts: 23
Post Re: Failed to connect to server...
The Traipse Fix worked for the GUI list. I could even connect to servers on it. The openrpg standard connected to server before I reinstalled Traipse, but not after. I tried to connect to another server in openrpg standard (while traipse was connected to another server successfully) but I got the failed to join error again. I'm hoping it's just an issue not on my end now. But at least I can connect using one of the two software.

Thank you

_________________
My Gaming Group's Home Page For All Our Games

My Pathfinder [3.7] Home Brewed Campaign Forum

My Pathfinder [3.7] Home Brewed Campaign Mayhem Gaming Forum


Wed Jun 09, 2010 3:22 pm
Profile WWW
User avatar

Joined: Wed Jun 09, 2010 1:24 am
Posts: 23
Post Re: Failed to connect to server...
Okay I found a work around for the Openrpg standard issue. If I load Traipse, everything works fine. If I load OpenRPG standard (1.8.0+) The GUI server list populates but checking a server and clicking the connect button yields a "Failed to connect to server..." error. Now If I go to the bookmark server list and connect that way, It connects me to the server just fine. I have tested this with a Windows 7 and Windows XP. Any clues why the software does this? I hope this helps anyone who has a similar problem. Thank you.

_________________
My Gaming Group's Home Page For All Our Games

My Pathfinder [3.7] Home Brewed Campaign Forum

My Pathfinder [3.7] Home Brewed Campaign Mayhem Gaming Forum


Mon Jun 14, 2010 6:34 pm
Profile WWW

Joined: Thu Dec 10, 2009 6:37 am
Posts: 335
Post Re: Failed to connect to server...
Does that workaround work for servers you hadn't bookmarked previously?


Mon Jun 14, 2010 10:01 pm
Profile
User avatar

Joined: Wed Jun 09, 2010 1:24 am
Posts: 23
Post Re: Failed to connect to server...
Yes, in fact that's how I first found it by bookmarking new servers. It boggles my mind but I can use the software if need be. On the plus side It gave me time to learn the namespace concept and application on Traipse. I hope this can at least help others who had similar problems like I had. Thank you.

_________________
My Gaming Group's Home Page For All Our Games

My Pathfinder [3.7] Home Brewed Campaign Forum

My Pathfinder [3.7] Home Brewed Campaign Mayhem Gaming Forum


Mon Jun 14, 2010 10:07 pm
Profile WWW

Joined: Thu Dec 10, 2009 6:37 am
Posts: 335
Post Re: Failed to connect to server...
Thanks for reporting the workaround.


Mon Jun 14, 2010 10:08 pm
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.